FCoE Implementations – Cisco CCNP and CCIE

Cisco Nexus devices support FCoE implementation including the Cisco Nexus 5000, 7000, 7700, 6000, and 9000 Series switches. Cisco MDS 9000 Series multilayer switches also support FCoE implementation.

In the Cisco Nexus 7000/7700 Series switches, each F Series module that runs FCoE requires an FCoE license. Also, FCoE does not require an additional VDC and is enabled in the storage VDC by default. On Cisco Nexus 5000 Series switches, FCoE capability is included in the Storage Protocol Services License, which needs to be activated by entering the feature fcoe command. FCoE is enabled on Cisco MDS Series switches by default although Cisco MDS series switches are mostly used for Fibre Channel connectivity. The Cisco NX-OS software supports FCoE with 10-Gigabit and 40-Gigabit Ethernet interfaces.

Because the implementation of FCoE is a little bit different in different NX-OS devices, we look at Cisco Nexus 7000 Series, Cisco Nexus 5000 Series, and Cisco Nexus 9000 Series implementations separately.

FCoE Configuration on Cisco Nexus 7000 Series Switches

Let’s first look into the configuration steps required to configure FCoE on Cisco Nexus 7000 Series switches.

Example 9-2 shows configuration tasks that need to be performed while you are configuring FCoE on Cisco Nexus 7000 Series switches.

Example 9-2 Sample FCoE Configuration on Nexus 7000 Series Switches

Step 1: Preparing the Switch for Configuring FCoE

! Firstly, you will need to install FCoE feature set and associate an FCoE license with an FCoE module
to configure FCoE. You need one license for each module configured for FCoE. Then enable no drop queue
for FCoE class.

switch# configure terminal
switch(config)# install feature-set fcoe
switch(config)# feature lldp
switch(config)# license fcoe module 2
switch(config)# system qos
switch(config-sys-qos)# service-policy type network-qos default-nq-7e-policy


Step 2: Creating and configuring Storage VDC

! Create a dedicated storage VDC and enable storage features in a storage VDC. You do not need to allow
the feature-set or enable it in the storage VDC because this process is handled automatically for a storage
VDC. Also you will need to allocate interfaces to the storage VDC as a dedicated FCoE port. You must
allocate all interfaces in the port group. You must configure these interfaces in switchport trunk mode
as Spanning Tree Protocol (STP) edge ports. Also ensure that you have allocated the FCoE VLAN range.

switch(config)# vdc fcoe type storage
switch(config-vdc)# allocate interface ethernet 2/1
switch(config-vdc)# allocate fcoe-vlan-range 10-30

switch(config)# interface ethernet 2/1
switch(config-if)# switchport mode trunk
switch(config-if)# spanning-tree port type edge trunk

! Enable LLDP feature and unshut the FCoE ports on storage VDC.

switch# switchto vdc fcoe type storage
switch-fcoe# configure terminal
switch-fcoe(config)# feature lldp
switch-fcoe(config)# interface ethernet 2/1
switch-fcoe(config-if)# no shutdown

Step 3: Configuring FCoE VLANs and Virtual Fibre Channel Interfaces
! A unique, dedicated VLAN must be configured at every converged access switch to carry traffic for each
virtual fabric (VSAN) in the SAN (for example, VLAN 200 for VSAN 200, VLAN 300 for VSAN 300, and so on).
If you enable MST, you must use a separate Multiple Spanning Tree (MST) instance for FCoE VLANs. In the
following example we allow VLAN 200 which will later be mapped to FCoE VSAN 200


switch-fcoe(config)# interface ethernet 2/1
switch-fcoe(config-if)# switchport trunk allowed vlan 1,200

switch-fcoe(config)# vsan database
switch-fcoe(config-vsan-db)# vsan 200

switch-fcoe(config)# vlan 200
switch-fcoe(config-vlan)# fcoe vsan 200

! To use FCoE, you must first create Virtual Fibre Channel (vFC) interfaces. Then, you must bind the
VFC interfaces to physical interfaces before FCoE can be used.

switch-fcoe(config)# interface vfc 2
switch-fcoe(config-if)# switchport mode e
switch-fcoe(config-if)# bind interface ethernet 2/1

! Configure the association between the VSAN and virtual Fibre Channel interface or virtual Fibre Channel
port channel.

switch-fcoe(config)# vsan database
switch-fcoe(config-vsan-db)# vsan 200 interface vfc 2
switch-fcoe(config-vsan-db)# exit

Miscellaneous FCoE Configuration

DCBX allows the switch to send a LAN Logical Link Status (LLS) message to a directly connected CNA. To disable LAN traffic on an FCoE link, enter the shutdown lan command to send an LLS-Down message to the CNA. This command causes all VLANs on the interface that are not enabled for FCoE to be brought down. If a VLAN on the interface is enabled for FCoE, it continues to carry SAN traffic without any interruption.

switch(config)# interface Ethernet 2/1
switch(config-if)# shutdown lan

The FCoE switch advertises its priority. The priority is used by the CNAs in the fabric to determine the best switch to connect to. You can configure the global fabric priority using the following command. The default value is 128. The range is from 0 (higher) to 255 (lower).

switch-fcoe(config)# fcoe fcf-priority 42

You can configure the interval for Fibre Channel fabric advertisement on the switch using the following command:

switch-fcoe(config)# fcoe fka-adv-period 8

The VFID check verifies that the VSAN configuration is correct on both ends of a VE link. You can turn off the VFID check for VE ports to allow VE loopback configuration between two VE ports on the same switch.

switch-fcoe(config)# fcoe veloopback

FCoE Configuration on Cisco Nexus 5000 Series Switches

Because there is no concept of storage VDC on Cisco Nexus 5000 Series switches, the configuration is a little bit different when it comes to FCoE configuration on these switches.

Example 9-3 shows configuration tasks that need to be performed while you are configuring FCoE on Cisco Nexus 5000 Series switches.

Leave a Reply

Your email address will not be published. Required fields are marked *