FCoE NPV is supported on the Cisco Nexus devices. It functions similarly to traditional FCoE. The FCoE NPV feature is an enhanced form of FIP snooping that provides a secure method to connect FCoE-capable hosts to an FCoE-capable FCoE forwarder (FCF) switch.
The FCoE NPV feature provides the following benefits:
FCoE NPV does not have the management and troubleshooting issues that are inherent to managing hosts remotely at the FCF.
FCoE NPV implements FIP snooping as an extension to the NPV function while retaining the traffic-engineering, vsan-management, administration, and troubleshooting aspects of NPV.
FCoE NPV and NPV together allow communication through FC and FCoE ports at the same time. This provides a smooth transition when moving from FC to FCoE topologies.
From a control plane perspective, FCoE NPV performs proxy functions toward the FCF and the hosts in order to load-balance logins from the hosts evenly across the available FCF uplink ports. An FCoE NPV bridge is VSAN-aware and capable of assigning VSANs to the hosts.
VSANs from the hosts must be created, and for each VSAN, a dedicated VLAN must also be created and mapped. The mapped VLAN is used to carry FIP and FCoE traffic for the corresponding VSAN. The VLAN-VSAN mapping must be configured consistently in the entire fabric.
For each host directly connected over Ethernet interfaces on the FCoE NPV bridge, a virtual Fibre Channel (vFC) interface must be created and bound to the Ethernet interface. By default, the vFC interface is configured in the F mode (VF port).
Connectivity from an FCoE NPV bridge to the FCF is only supported over point-to-point links. These links can be individual Ethernet interfaces or members of an Ethernet port channel interface. For each FCF-connected Ethernet interface, a vFC interface must be created and bound to the Ethernet interface. These vFC interfaces must be configured as VNP ports. On the VNP port, an FCoE NPV bridge emulates an FCoE-capable host with multiple ENodes, each with a unique ENode MAC address. By default, the VNP port is enabled in trunk mode.
Example 9-6 shows configuration tasks that need to be performed while you are configuring FCoE NPV on Cisco Nexus 5000 Series switches on the sample topology shown in Figure 9-21.
Figure 9-21 Sample Topology for FCoE NPV
Example 9-6 Sample FCoE NPV Configuration on Nexus 5000 Series Switches
Step 1: Enable FCoE NPV
! You can enable FCoE NPV using the feature fcoe-npv command.
npv-switch# configure terminal
npv-switch(config)# feature fcoe-npv
Step 2: Enable FCoE QoS
npv-switch(config)# system qos
npv-switch(config-sys-qos)# service-policy type qos input fcoe-default-in-policy
npv-switch(config-sys-qos)# service-policy type queuing input fcoe-default-in-policy
npv-switch(config-sys-qos)# service-policy type queuing output fcoe-default-out-policy
npv-switch(config-sys-qos)# service-policy type network-qos fcoe-default-nq-policy
Step 3: Configuring VLAN to VSAN mapping
npv-switch(config)# vsan database
npv-switch(config-vsan-db)# vsan 50
npv-switch(config-vsan-db)# vlan 50
npv-switch(config-vlan)# fcoe vsan 50
Step 4: VNP Port configuration
npv-switch(config)# int e1/1
npv-switch(config-if)# switchport mode trunk
npv-switch(config-if)# switchport trunk allowed vlan 50
npv-switch(config-if)# no shut
! Create a vFC port and bind it to an Ethernet port. Set the port mode to NP and bring up the port.
npv-switch# config t
npv-switch(config)# interface vfc 20
npv-switch(config-if)# switchport mode NP
npv-switch(config-if)# bind interface ethernet 1/1
npv-switch(config-if)# switchport trunk allowed vsan 50
npv-switch(config-if)# no shutdown
Step 5: VF Port configuration
! A similar configuration must be applied to the NPIV side of the link. The primary difference is that
the vFC is configured for the VF mode and NPIV is enabled.
npiv-switch(config)# feature npiv
npiv-switch(config)# interface Ethernet1/2
npiv-switch(config-if)# switchport
npiv-switch(config-if)# switchport mode trunk
npiv-switch(config-if)# switchport trunk allowed vlan 50
npiv-switch(config-if)# no shutdown
! Create a vFC port and bind it to an Ethernet port. Set the port mode to F and bring up the port.
npiv-switch(config-if)# interface vfc20
npiv-switch(config-if)# switchport mode F
npiv-switch(config-if)# bind interface Ethernet1/2
npiv-switch(config-if)# switchport trunk allowed vsan 50
npiv-switch(config-if)# no shutdown
The FCoE NPV configuration on Nexus 9000 Series switches is similar to the configuration shown in Example 9-6. However, the only difference is that in Nexus 9000 Series switches, FCoE NPV feature is installed and enabled on the npv-switch using the command install feature-set fcoe-npv and feature-set fcoe-npv respectively.